News & Whatever

Pro Tools version 12.4 - Warning

ProTools 12 1.15AVID recently released version 12.4 of Pro Tools, and like many of you -- I went ahead and attempted to upgrade. I encountered some serious problems, at least in the Windows version. Be forewarned!

I attempted to install the software a couple of times onto my desktop (AMD quad, Win7, 64 bit). You could use the AVID Product Manager and just click to update... and the app does the rest. Or, you could delete Pro Tools, and the run the 12.4 installer from the AVID website.

I tried it both ways; same result. The program did install (after the multiple reboots that it requires), and you probably will have to delete and then re-install the iLok License manager (more reboots). After that, Pro Tools should be able to open.

However, my version of Pro Tools 12.4 (Win7-64bit) would only open around half of my stored sessions. Some old, some new. Some stored in the Pro Tools Audio Sessions directory, some not. Many times, it would fail to open a session or template and give me an error message:

Could not complete the Open Session command because Access violation occurred, unable to read location: 0x0000000000000000

Pro Tools would open some of my stored sessions, but not all of them. I tried a few fixes that were posted on various forums, but none of them worked. Running Pro Tools in Windows 7 compatability mode made things even worse: the audio engine sputtered and distorted the files that DID open.

I ended up un-installing Pro Tools 12.4 from my desktop and re-installed the older 12.3.1  All of the previous problems opening session files went away; everything worked fine again.

Feeling gutsy, I then tried upgrading to 12.4 on my PC laptop (Win8.1, 64 bit, i5). Completely different machine than my desktop. In fact, I use my laptop routinely for Pro Tools, since I can dock it to a couple of very large monitors and a good pair of Edirol speakers.

After getting the newer Pro Tools installed and open, I ran into the exact same problem and error message. Again, some of my sessions would open and others would not. Recent sessions, older sessions. In the PT directory, not in the directory. Could not find any pattern.

The real hassle was in getting rid of the 12.4 and re-installing the older 12.3.1  No matter what I tried, the new AVID HD Driver 12.4 would not be removed; and the 12.3.1 software would not work with the newer driver.

The only thing that I could do, in the end, was a full system restore to 48 hours prior to the 12.4 install. It took a long time, but when the computer finally came back online -- I found the older AVID HD Driver 12.3 was in place, along with my older install of Pro Tools 12.3.1  

The system restore did remove the latest Windows updates, so I did run the Update utility again to put them back.

Of course, Pro Tools still would not open.... so I ran the program REPAIR option which essentially re-installed the software. That did the trick! Pro Tools 12.3.1 was now back on the machine and running fine again. All of the session files on my drive opened okay, even the ones that refused to work in 12.4

Am I the only one who experienced this? Is version 12.4 (Windows) flawed, or am I doing something hopelessly wrong? I have not read about similar issues in the Mac version; but have heard nothing either way from other Windows users.

Send me your feedback.